Add Me!Close Menu Navigation
Полный список уроков excel

Число прописью в excel

Как написать число прописью в excel? Такой вопрос, пожалуй, чаще всего возникает в бухгалтерской сфере использования excel.

Мне известны три варианта:

1-сделать это традиционно вручную

2- использовать макросы

3-другое

Вручную — долго, с макросами процедуру придется проделывать каждый раз, поэтому рассмотрим вариант «другое».

Данный способ позволит использовать функцию «суммапрописью» всегда, когда понадобится, с минимальными усилиями.

Для этого скачайте специальную програмку здесь, и далее следуюйте инструкции:

- Скопировать файл MYXAS32.XLL в папку «C:\Program Files\Microsoft Office\Office\Library», если Office у вас 2000/ХР или в папку «Library» по похожему пути.
- Открыть Excel >> меню «Сервис» >> «Надстройки» >> поставить там галочку напротив «Excellerator». Если такого пункта нет, то нажать кнопку обзор и найти файл MYXAS32.XLL, выбрать его, нажать «Ок»
- И все!
- Теперь для того чтобы у вас писалась сумму прописью надо в ту ячейку, где должна быть сумма прописью вставить формулу «=суммапрописью(A1)», где А1 — сумма в числовом формате

ДОПОЛНИТЕЛЬНАЯ ИНФОРМАЦИЯ:

1.если нужно поменять валюту, делаем настройки как здесь, вместо долларов можно вписывать любой вид валюты.
2. если нужно вообще убрать валюту, чтобы просто писалось число прописью без знаков после запятой, делаем настройки как здесь. В графе падежи рублей и падежи копеек после запятой стоит ПРОБЕЛ-это важно.
3.если надо, чтобы копейки после запятой не указывались, в настройках функции дробность ставьте -1, пример
4. если нужно, чтобы писалась не валюта, а просто математические названия-целые, десятые, сотые, тысячные, делаем настройки как здесь, но можно не более трех знаков после запятой.
5. если надо, чтобы сумма указывалась в скобках, в строке формул должно быть вот так , где В3 — это ячейка с числовым значением.

БЕСПЛАТНЫЙ БАЗОВЫЙ КУРС по работе в excel
В этом курсе Вы узнаете:

  • Как устроен интерфейс MS Excel.
  • Как создавать и схоранять рабочие листы.
  • Как управлять их содержимым, вводить и редактировать данные.
  • Как форматировать числа, текст и даты
  • Как менять внешний вид ячеек
  • Как настраивать книгу для печати.
  • Как использовать простейшие формулы.
  • И особенности копирования формул(что делает работу в программе значительно быстрее).

Popularity: 40% [?]

поведал admin

121 - Комментарии к записи “Число прописью в excel”

  1. Пётр:

    Спасибо за ответ, но к сожалению, без копеек пока никак(

  2. admin:

    Петр: к сожалению, копейки в этой надстройке словами не будут писаться:( может их убрать вообще? и нет проблем:)

  3. Пётр:

    Добрый день
    подскажите что нужно сделать, чтобы копейки тоже писались словами
    Спасибо

  4. admin:

    Рома: пишите в строке формул как тут B3 — это ячейка с числом, которое должно быть прописью.

  5. admin:

    Татьяна: вот посмотрите на рисунке,что должно быть в строке формул. там кавычки должны быть как две палочки вертикальные, у меня просто рекдактор их автоматом изменяет на вот такие «

  6. Татьяна:

    Здравствуйте. программа замечательно, здорово все, но помогите не могу скобки по вашей формуле поставить. Ошибку ставит и все. Можно как то по другому скобки поставить в прописи суммы?

  7. Рома:

    здравствуйте , как сделать сумму в скобках , как в примере не получается : 5. если надо, чтобы сумма указывалась в скобках, в строке формул должно быть вот так =»(«&ТЕКСТ(СуммаПрописью(B3);»0″)&»)» , где В3 — это ячейка с числовым значением.

  8. admin:

    Натали: трудно сказать, в чем причина, надо смотреть конкретно ваши листы. присылайте на почту vizushka@mail.ru

  9. Натали:

    Помогите, пожалуйста, все прописала и все работало, по вашим инструкциям, спасибо! Но через пару месяцев началось что-то непонятное, при копировании «листа» в excel в пределах одной «книги» сама формула «сумма прописью» копируется, но значение нет? и ставится #ИМЯ? хотя при нажатии на эту ячейку в строке прописана формула? что это может быть и как исправить?

  10. admin:

    Евгений: аа, не поняла сразу:)) да, с 1 и 2 провал:)) но дописать я не смогу помочь:(

  11. Евгений:

    Ок. Но у меня получится один гривн и два гривны, а правильно должно быть одна гривна и две гривны. Фишка в том, что формулу писали под рубль. Рубль — мужской род, гривна — женский. То есть в самом XLL файле должно быть прописано 1 = «одна», 2 = «две». Как это сделать я не знаю, может подскажете?
    СПС

  12. admin:

    Евгений: да, вы вписывайте по родам и падежам валюту как здесь, только гривна, гривны, гривен,1 и копейки также по падежам, и все.

  13. Евгений:

    Добрый день.
    Подскажите, есть ли возможность подстроить формулу под род (мужской или женский) валюты? Например, доллар — один, а гривна — одна. Таким образом, используя данную версию формулы у меня получится один гривна, два гривны. Должно быть одна гривна, две гривны.
    СПС

  14. Сергей:

    Прошу прощения, в предыдущий текст вкрались досадные ошибки, поэтому предлагаю исправленный текст:
    В некоторых документах (хотя и нечасто) требуется, чтобы строка «суммы прописью» состояла из числового значения
    основной валюты (в данном случае — рублей) с последующей текстовой расшифровкой в скобках, названия валюты, числового
    значения дробных денежных единиц и их названия.
    Например: «4533 (четыре тысячи пятьсот тридцать три) рубля 00 копеек.», или «4533 (четыре тысячи пятьсот тридцать три) рубля 00 копеек» — без точки в конце фразы,
    или, когда количество дробных денежных единиц равно нулю и отображать их не нужно: «4533 (четыре тысячи пятьсот тридцать три) рубля. (c точкой или без)».
    Создать такую автоматически скомпонованную строку непросто, но, как говорится, нет ничего невозможного…
    Ниже мной предлагаются варианты формул, позволяющие полностью автоматически формировать указанные строки.
    Примечание 1: Все формулы действуют только в русскоязычной версии «Excel»;
    Примечание 2: Разумеется, адреса ячеек в формулах (т.е.: А1, А2, А3, А4) приведены произвольно.

    Вариант № 1: нужно получить «4533 (четыре тысячи пятьсот тридцать три) рубля 80 копеек.» (с точкой в конце строки или без).
    Значение в ячейке A1(в финансовом формате без указания валюты): 4000,00
    Значение в ячейке A2 (в финансовом формате без указания валюты): 533,80
    Формула в ячейке А3: =СУММ(А1:А2)
    Результат в ячейке А3 (в финансовом формате без указания валюты, или в числовом формате типа «0,00″): 4533,80

    Формула в ячейке А4:
    =ТЕКСТ(ЦЕЛОЕ(А3);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(A3;» , , ,0″;» , , ,1″;-1);0)))&»)»&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0))))&» «&ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0))))&».»

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) рубля 80 копеек.

    Если точка в конце строки не нужна, то формула выглядит так:
    =ТЕКСТ(ЦЕЛОЕ(A22);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(A3;» , , ,0″;» , , ,1″;-1);0)))&»)»&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3;;;-1);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3;;;-1);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3;;;-1);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3;;;-1);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3;;;-1);0))))&» «&ПРАВСИМВ(ТЕКСТ(A3;»0,00″);2)&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(A3);0))))

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) рубля 80 копеек

    Если при нулевых значениях копеек информация о них не должна отображаться, то:
    Вариант № 2: нужно получить «4533 (четыре тысячи пятьсот тридцать три) рубля» (с точкой в конце строки или без).
    Значение в ячейке A1(в финансовом формате без указания валюты): 4000,00
    Значение в ячейке A2 (в финансовом формате без указания валюты): 533,00
    Формула в ячейке А3: =СУММ(А1:А2)
    Результат в ячейке А3 (в финансовом формате без указания валюты, или в числовом формате типа «0,00″): 4533,00
    Формула в ячейке А4:

    =ТЕКСТ(ЦЕЛОЕ(А3);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(А3;» , , ,0″;» , , ,1″;-1);0)))&»)»&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0))))&ЕСЛИ(ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)»00″;» «&ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0))));»")

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) рубля (без точки в конце)
    Если нужно, чтобы в конце этого текста стояла точка, замените самый последний символ формулы /»"/ на /».»/,
    например: формула…;0))));»") => формула…;0))));».»)

    Если в тексте допускаются несклоняемые названия денежных единиц (например, сокращения: «руб.», «коп.»), то формулы
    значительно упрощаются:

    1 вариант
    =ТЕКСТ(ЦЕЛОЕ(А3);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(A3;» , , ,0″;» , , ,1″;-1);0)))&»)»&» руб. «&ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)&» коп. »

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) руб. 80 коп.

    2 вариант
    =ТЕКСТ(ЦЕЛОЕ(А3);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(А3;» , , ,0″;» , , ,1″;-1);0)))&»)»&» руб.»&ЕСЛИ(ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)»00″;» «&ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)&» коп.»;»")

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) руб.

    С уважением, Мартынов С.А.

  15. Сергей:

    В некоторых документах (хотя и нечасто) требуется, чтобы строка «суммы прописью» состояла из числового значения
    основной валюты (в данном случае — рублей)с последующей текстовой расшифровкой в скобках, названия валюты, числового
    значения дробных денежных единиц и их названия.
    Например: «4533 (четыре тысячи пятьсот тридцать три) рубля 00 копеек.», или «4533 (четыре тысячи пятьсот тридцать три) рубля 00 копеек» — без точки в конце фразы,
    или, когда количество дробных денежных единиц равно нулю и отображать их не нужно: «4533 (четыре тысячи пятьсот тридцать три) рубля. (точкой или без)».
    Создать такую автоматически скомпонованную строку непросто, но, как говорится, нет ничего невозможного…
    Ниже мной предлагаются варианты формул, позволяющие полностью автоматически формировать указанные строки.
    Примечание 1: Все формулы действуют только в русскоязычной версии «Excel»;
    Примечание 2: Разумеется, адреса ячеек в формулах (т.е.: А1, А2, А3, А4) приведены произвольно.

    Вариант № 1: нужно получить «4533 (четыре тысячи пятьсот тридцать три) рубля 80 копеек.» (с точкой в конце строки или без).
    Значение в ячейке A1(в финансовом формате без указания валюты): 4000,00
    Значение в ячейке A2 (в финансовом формате без указания валюты): 533,80
    Формула в ячейке А3: =СУММ(А1:А2)
    Результат в ячейке А3 (в финансовом формате без указания валюты, или в числовом формате типа «0,00″): 4533,80

    Формула в ячейке А4:
    =ТЕКСТ(ЦЕЛОЕ(А3);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(G22;» , , ,0″;» , , ,1″;-1);0)))&»)»&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0))))&» «&ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0))))&».»

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) рубля 80 копеек.

    Если точка в конце строки не нужна, то формула выглядит так:
    =ТЕКСТ(ЦЕЛОЕ(G22);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(G22;» , , ,0″;» , , ,1″;-1);0)))&»)»&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22;;;-1);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22;;;-1);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22;;;-1);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22;;;-1);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22;;;-1);0))))&» «&ПРАВСИМВ(ТЕКСТ(G22;»0,00″);2)&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(G22);0))))

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) рубля 80 копеек

    Если при нулевых значениях копеек информация о них не должна отображаться, то:
    Вариант № 2: нужно получить «4533 (четыре тысячи пятьсот тридцать три) рубля» (с точкой в конце строки или без).
    Значение в ячейке A1(в финансовом формате без указания валюты): 4000,00
    Значение в ячейке A2 (в финансовом формате без указания валюты): 533,00
    Формула в ячейке А3: =СУММ(А1:А2)
    Результат в ячейке А3 (в финансовом формате без указания валюты, или в числовом формате типа «0,00″): 4533,00
    Формула в ячейке А4:

    =ТЕКСТ(ЦЕЛОЕ(А3);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(А3;» , , ,0″;» , , ,1″;-1);0)))&»)»&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3;;;-1);0))))&ЕСЛИ(ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)»00″;» «&ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)&» «&ПСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));НАЙТИ(«*»;ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));» «;»*»;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0)))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0));» «;»"))))+1;ДЛСТР(СЖПРОБЕЛЫ(ТЕКСТ(СуммаПрописью(А3);0))));»")

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) рубля (без точки в конце)
    Если нужно, чтобы в конце этого текста стояла точка, замените самый последний символ формулы /»"/ на /».»/,
    например: формула…;0))));»") => формула…;0))));».»)

    Если в тексте допускаются несклоняемые названия денежных единиц (например, сокращения: «руб.», «коп.»), то формулы
    значительно упрощаются:

    1 вариант
    =ТЕКСТ(ЦЕЛОЕ(А3);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(G22;» , , ,0″;» , , ,1″;-1);0)))&»)»&» руб. «&ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)&» коп. »

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) руб. 80 коп.

    2 вариант
    =ТЕКСТ(ЦЕЛОЕ(А3);0)&» «&»(«&СЖПРОБЕЛЫ(СТРОЧН(ТЕКСТ(СуммаПрописью(А3;» , , ,0″;» , , ,1″;-1);0)))&»)»&» руб.»&ЕСЛИ(ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)»00″;» «&ПРАВСИМВ(ТЕКСТ(А3;»0,00″);2)&» коп.»;»")

    //Результат в ячейке А4: 4533 (четыре тысячи пятьсот тридцать три) руб.

    С уважением, Мартынов С.А.

  16. admin:

    Сергей:да, именно так и есть.

  17. Сергей:

    Низкий вам поклон! Почитав обсуждение, понял, что большинство вопросов происходит от недостаточного понимания синтаксиса формул в Excel.

  18. Игорь:

    А, понял перед КАЖДОЙ и после КАЖДОЙ Ззаптой ставится пробел

  19. Игорь:

    admin:
    все ровно в конце добавляет букву! :-(

  20. admin:

    Игорь: надо в графе падежи рублей вот так написать «h, ,h,h» второй знак ставить пробел, а не третий!!! а лучше вообще все поставить пробелы. см. пример

  21. Игорь:

    2. если нужно вообще убрать валюту, чтобы просто писалось число прописью без знаков после запятой, делаем настройки как здесь. В графе падежи рублей и падежи копеек после первой запятой стоит ПРОБЕЛ-это важно, буква h стоит для примера, можно ставить любую, какая больше нравится:)

    Добрый день! Делаю всё, как описанов выше, НО в конце преобразованного в текст числа появляется выбранная буква (Например, h). Пример Семь тысяч пятьсот одиннадцать h

  22. admin:

    BraG.A: к сожалению в данной надстройке не сделаешь так, чтобы писались копейки только при условии, что они есть…

  23. BraG.A:

    Сперва хочу сказать огромное спасибо автору.

    Но возник один вопрос:
    Возможно ли сделать, что бы писало копейки лишь в том случаи, когда они есть?
    Пример:
    •как сейчас:
    207.00 — Двести семь рублей 00 копеек
    207.10 — Двести семь рублей десять копеек
    •как хотелось бы:
    207.00 — Двести семь рублей
    207.10 — Двести семь рублей десять копеек

  24. Спасибо! Всё работает!!!

  25. admin:

    Влад: да, если надо, чтобы писались цифры после запятой, в настройках в графе падежи копеек первый знак обязательно должен быть заполнен, иначе цифры после запятой вообще не будут указываться, таково устройство данной функции. чтобы не печаталось h или любой другой знак, предлагаю просто поставить точку: =СуммаПрописью(B4;» , , ,1″;»., , ,3″;4)

  26. Здравствуйте!
    Нужно, чтобы сумма целых была прописью, а тысячные после запятой — цифрами. Без рублей и копеек.
    Вбил формулу СуммаПрописью(B7;» , , ,0″;»h, , ,1″;3).
    Но если последняя цифра равна 1, то пишет в конце h.
    Например,
    если 5841,991, то «пять тысяч восемьсот сорок одна 991 h».
    Как быть?

  27. admin:

    декстер: пожалуйста:) грамоту можете на почту отправить:)) vizushka@mail.ru , для таллеров есть яндекс кошелек 41001261225289

  28. декстер:

    спасибо ребята, респект вам и уважуха. куда отправить благодарность?

  29. Анна:

    Ну наконец-то,все просто и лаконично.Благодарствую)

  30. Антонина:

    Огромное спасибо за эту функцию, а то с макросами уже замучилась!

  31. Александра:

    СПАСИБО ОГРОМНОЕ)))

Оставьте комментарий




Рубрики